Системные требования Webim для посетителя

На этой странице описаны системные требования, предъявляемые к системам, на которых запускается приложение Webim для посетителя пользовательского сайта, то есть окно веб-чата для связи с оператором.

Содержание

 

Сервис онлайн-консультирования Webim является веб-службой в сети Интернет. Для работы с системой не требуется установки никакого дополнительного обеспечения на компьютеры пользователей. Ваши пользователи просто просматривают страницы сайта компании в браузере. Весь код, необходимый для работы веб-чата, загрузится на их компьютер автоматически.

Поэтому сервисом Webim 9.x поддерживаются любые компьютеры, планшеты или смартфоны под управлением любой операционной системы (Microsoft Windows, Mac OS X, Apple iOS, Google Android, Linux, UNIX и т. д.), на котором установлен веб-браузер, кроме безнадёжно устаревших.

Webim поддерживает большинство распространённых браузеров. К настройкам браузера предъявляются легко выполнимые требования, типовые для всех современных веб-сервисов. Они подробно описаны на этой странице.

См. также Как узнать версию моего браузера

Список полностью поддерживаемых браузеров

Webim версии 9.2 успешно протестирован на совместимость со следующими браузерами:

Модель браузера Поддерживаемые версии Особенности
Google Chrome (не включая Chrome Mobile) 49 и новее Chrome - эталонный браузер, рекомендуется разработчиками к использованию.
Mozilla Firefox (не включая Firefox Mobile) 52 и новее Иногда наблюдается нестабильная работа кобраузинга.
Apple Safari для Mac 10.1 и новее Точный номер версии ОС не сообщается серверу, все рапортуются как Mac OS X.
Телепорт - непонятно.
Microsoft Edge 25 и новее Могут наблюдаться косметические проблемы с вёрсткой.
Microsoft Internet Explorer 10 - 11 Могут наблюдаться косметические проблемы с вёрсткой.
Apple Safari для iOS 10.3 и новее

Список частично поддерживаемых браузеров

В следующем списке приведены модели браузеров, в которых базовая функциональность веб-чата Webim поддерживается, но некоторые дополнительные функции недоступны:

Модель браузера Поддерживаемые версии Недоступная функциональность
Google Chrome для Android 59 и новее Кобраузинг.
Mozilla Firefox для Android 52 и новее Кобраузинг.
Могут наблюдаться косметические проблемы с вёрсткой, особенно в версиях между 52 и 62 включительно.
Opera (Desktop) 12 - 35 Кобраузинг.
Телепорт не поддерживается
Иногда могут наблюдаться проблемы с окном чата.
Иногда могут не доставляться сообщения.
Минорный номер версии ОС не сообщается серверу.
Opera (не включая Mobile) 36 и новее Телепорт не поддерживается
Opera Neon 1 и новее Опознаётся как Chrome.
Телепорт не поддерживается.
Opera Mobile 42 и новее Кобраузинг.
Могут наблюдаться косметические проблемы с версткой.
Yandex Browser 17 и новее Отправка файлов между посетителем и оператором.
Maxthon 5 (MX5) и новее Отправка файлов от посетителя оператору.
Иногда окно чата становится пустым, и обновление страницы не помогает.
Телепорт - непонятно.
Mozilla Firefox 49 - 51
Apple Safari для Mac 9.1
Apple Safari для Windows 5.1 и новее Кобраузинг не поддерживается.
Минорный номер версии ОС не сообщается серверу (например, Windows 8.1 будет рапортоваться как 8).


 

Требования к настройкам браузера

В браузере должны быть включены следующие опции:

  • Поддержка Javascript,
  • Поддержка cookies,
  • Поддержка кириллицы.

Также желательно, но необязательно, включить следующие опции:

  • Отображение изображений (картинок),
  • Определение местоположения,
  • Доступ к контенту по защищённым каналам.

Точный алгоритм включения этих опций зависит от модели и даже версии браузера. Если не знаете, как включить или проверить эти опции, обратитесь к своему системному администратору.

Для некоторых случаев мы приготовили готовые инструкции: